Renault Forums :: Independent Renault forum - View Single Post - Megane II multiple electrical problems.

View Single Post
post #1 of (permalink) Old 15th October 2009 Thread Starter
Junior Member
Join Date: Oct 2009
Posts: 4
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Megane II multiple electrical problems.

I have several problems with my 2004 megane 1.6 (43K miles).

1) O/S rear window doesn't work and is stuck down. I have stripped door trim. I removed the white connector from the window switch and checked the voltage at the connector. When compared to the other side (which works) there is no voltage to the pink and green wires.

2) Car has keyless entry and used to unlock without use of remote when you pulled the door handle. Also used to lock when you pressed the button on door after getting out of car. Now you have to use the remote buttons to lock/unlock the car.

3) Centre display (car has built in sat nav) has gone completely crazy. Display flickers/disapears or is sometimes upside down!

Any help would be appreciated!!!
Currently in hamsterwind's garage:
2004 Megane 1.6 16v Dynamique Auto
hamsterwind is offline  
  5 Lastest Threads by hamsterwind
Thread Forum Last Poster Replies Views Last Post
Sat Nav LCD display problem. Electronics just12310 1 1932 22nd March 2010 07:30 PM
Megane II multiple electrical problems. Electronics cph1984 5 2217 15th October 2009 08:26 PM
For the best viewing experience please update your browser to Google Chrome