Renault Forums :: Independent Renault forum - View Single Post - Clio Aziz ECU

Thread: Clio Aziz ECU
View Single Post
post #1 of (permalink) Old 16th October 2009 Thread Starter
Junior Member
Join Date: Oct 2009
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Clio Aziz ECU

Hi all, recently i broke down in a Clio Aziz a V reg. I had driven 5 mile in my car, stopped then when i went to get back in it would not start. I called the breakdown club i am in and they sent a mechanic to me who tried to start the car.

I suspected the battery had gone flat for some reason and the mechanic seemed to think this was the case.

He attached some jump leads from his truck, started it and it was ticking over and all seemed fine. When he removed the jump leads switched off the engine and tried starting the vehicle it still would not start so he then re-attached the jump leads and tried starting the engine again. This time it seemed to start but then cut out and would not idle. The mechanic mentioned, that it was strange it wouldn't idle on tick over now.

Now the problem is that my ECU needs replacing. I was told by someone that if the ECU had already been broken before the mechanic got to my car the vehicle would not have started and idled on tick over. Then when he jump started it again it would not idle on the tick over like it had earlier.

Is there an idling component in the ECU that could have been damaged? It's going to cost me £400 to get the ECU fixed for what appeared to be a flat battery.

Could this damage have occurred with a jump start on the vehicle?

Sorry for the long post but i could do with some help thank you.
rescueme is offline  
  5 Lastest Threads by rescueme
Thread Forum Last Poster Replies Views Last Post
Clio Aziz ECU Electronics Hopless 1 705 16th October 2009 12:02 PM
For the best viewing experience please update your browser to Google Chrome