Renault Forums :: Independent Renault forum - View Single Post - Laguna II, 2003, water in footwells

View Single Post
post #3 of (permalink) Old 29th November 2009 Thread Starter
Junior Member
Join Date: Sep 2009
Posts: 15
Nominated 0 Times in 0 Posts
Nominated TOTW/F/M Award(s): 1
Thanks: 0
Thanked 12 Times in 1 Post
Re: Laguna II, 2003, water in footwells

Originally Posted by peter r View Post
Thanks for that...we had already checked the sun roof, so this sounds promising, especailly as the leak has now hit the satnav in the glove box. Have talked to others with this problem so hopefully one of many problems will go away..
Just leaves horrible noise when excellerating in low gear...not the engine mounts,
The intermitently locking doors that dont open from outside...changed the door locks,
including the filler cap.
The light on the heater panel....interesting selection in the dark.
The rear heated screen that no longer works.
The wheel sensors that always read low....on the wrong sides...and yes ive checked the code...
I luv my Lag......
My mechanic buddy told me these were solid reliable cars! Reading these threads worry me, My heater display is fun in the dark too, wasn't sure it was supposed to light as everything else is working, the water in from around the bulk head can't be good for electronics especially as when it drys out it will condensate and cause corrotion on electronic parts! Just like splashing your video or stills camera.
The only other thing I am not confident about is the pressure sensors, they ruin them at the tire shop as they have lack of knowledge when they rip your old tires off, but why they read low on the wrong side is an odd one. I pray my Lag keeps going for 6 months then I will decide where it's home is meant to be..

Good luck Peter,


mustangbazza is offline  
For the best viewing experience please update your browser to Google Chrome