Renault Forums :: Independent Renault forum - View Single Post - TDC Sensor Replacement (with pictures!)

View Single Post
post #195 of (permalink) Old 12th December 2009
chris m
Let's be carefull out there
chris m's Avatar
Join Date: Jan 2006
Posts: 19,344
Nominated 1 Time in 1 Post
Nominated TOTW/F/M Award(s): 3
Thanks: 3
Thanked 32 Times in 32 Posts
Send a message via MSN to chris m
Re: TDC Sensor Replacement (with pictures!)

Originally Posted by bluesnapper View Post
Just stumbled onto this forum.

Right this is my problem.

Three weeks ago my Megane (1996) RT 1.6 would not start, the engine turned but failed to start.

Because of how cold it was I decided to charge the battery over a couple of days just to make sure it was not that.

Put the battery back in and the same problem occured.

Called out the RAC he could not get it to go. Reckoned it was a flooded engine because there was a spark but the plugs stunk of petrol. He dried and replaced the plugs four times and still the same problem.

He recommended I take it to a garage. The garage reckoned the same but he found I only had good compression in one pot (#4). He said it would start with a tow, but if it didnt he was talking more of a serious engine problem that would cost more to fix than the car was worth.

Now seeing this thread could it be the TDC Sensor being at fault given the lack of compression, spark at the plugs and the plugs coated in petrol?
I would have thought the TDC would not give a spark at the plugs if faulty. However, worth a clean before paying good money
Currently in chris m's garage:
2000 Scenic 2.0 16v Monaco, BMW 3 Series, Pug 206
chris m is offline  
For the best viewing experience please update your browser to Google Chrome