Renault Forums :: Independent Renault forum - View Single Post - Laguna Mk1 Front CrossMember Corrosion - MOT failure

View Single Post
post #17 of (permalink) Old 13th December 2009 Thread Starter
Join Date: Feb 2007
Posts: 33
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Laguna Mk1 Front CrossMember Corrosion - MOT failure

Just wanted to say that I've now done the radiator support panel. It's a much easier job than I expected. Basically:

1: support the radiator. I used one of those sliding clamps with a trigger, and clamped the radiator fan mounting to the middle of the top cross-member (in between the two bonnet catches. I also used to bungee ropes.
2: Un-bolted the plastic wheel arch under-shields
3: Un-bolted the plastic grills, also under the wheel arches (need a torx screw for that)
4: Un-bolted the 4 bolts running across the from of the radiator support panel, holding on the front-bottom panel that goes to the front, under the bumper.
5: Un-clipped the washers that are on the bottom of the two pegs coming from the bottom of the radiator
6: Un-clipped the pipes from the plastic clips facing down at the rear of the radiator support panel
7: Un-bolted the two bolts holding the radiator support panel up and took it out from underneath
8: I transferred the two rubber washers that support the pegs at the bottom of the radiator to the new panel, and also the plastic clips that hold the pipes at the back of the panel (that face downwards). I had to glue these as well as screwing them on.
9: Put it all back together in reverse order

Very easy with the correct tools. That clamp was worth its weight in gold!

Unfortunately, I've found that my drive-shaft gaiter split is back, so I'm going to have to do the job properly, and that's todays job!

Thanks for all the help
Currently in tombardier's garage:
1996 renault laguna RXE 2.0i
tombardier is offline  
For the best viewing experience please update your browser to Google Chrome