Renault Forums :: Independent Renault forum - View Single Post - Renault Clio 2 - Horn And Handbrake Questions

View Single Post
post #3 of (permalink) Old 21st December 2009
Veteran Member
Technical Supremo
Lagdti's Avatar
Join Date: Dec 2005
Posts: 40,429
Nominated 2 Times in 20 Posts
Nominated TOTW/F/M Award(s): 18
Thanks: 149
Thanked 1,103 Times in 942 Posts
Re: no horn and high handbrake

I think you need to show a little more patience to be honest,and posting in the correct sections would help.As your new we'll let you off though(welcome to the forum by the way).

For the horn,you need to see if you have a feed and earth to it when you press the button.The horn it's self is hidden up under the front bumper somewhere,you'll need a multimeter or test light to check for a feed,if you have a feed when the button is pressed and the horn doesn't sound,then it's the horn.If you don't have a feed,then it's a wiring or button fault.9 times out of 10 it's the horn it's self,but it's always worth checking the above first.

When adjusting the handbrake,it's always a good idea to check the shoes and adjust them first,you then adjust the cable afterwards if needs be.When you check inside of the drum,check the wheel cylinders for signs that they are weeping brake fluid(replace if so),check the handbrake arms are free and not seized,also make sure that the non-return nib is present on the adjusters as otherwise they will gradually 'unadjust' and you'll have a long handbrake again.

There is no set limit on how many clicks a handbrake should be for the MOT,as long as there is reserve travel at the top of the lever and the handbrake works OK in the rollers then it will be OK.
Currently in Lagdti's garage:
2004 Saab 9-5 HOT Aero and a 2001 Audi A3 1.8 Turbo
Lagdti is offline  
For the best viewing experience please update your browser to Google Chrome