Renault Forums :: Independent Renault forum - View Single Post - Renault Laguna 1 - Heated Rear Window Not Working*FIXED*

View Single Post
post #4 of (permalink) Old 9th January 2010 Thread Starter
Junior Member
Dee33's Avatar
Join Date: Sep 2009
Posts: 23
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Talking Re: Laguna RT Sport 1996 - REAR DEMISTER PROBLEM

Now solved!!!
Cause: As well as the connector in the boot, there is also a connector located behind the left plastic panel on the front passenger area, i.e. imagine where the passenger's left ankle would be, you should see the wiring loom going down behind the panel.

I pulled the panel out as well as across the side (towards the middle of the car - still to the left of the passenger) in order to get better leverage and clearance of the connector.

After pulling the connector's safety lever down, and a slight squeeze on the right side, I then disconnected the two halves of the connector, while ensuring the ignition was switched off and keys out.

Looking into the lower half of the connector I could see that it was a bit corroded, as if water-damaged. I then sprayed a good amount of WD-40 inside (using the straw in the nozzle of the spray for better coverage), particularly into the holes which house the thick white wire, in both halves, allowing to run into the holes and wiring (for about 5 seconds), then let the excess run out again.I then done the same for the top connector, i.e. spraying some in which run out itself again.

As I had a little trouble re-connecting the two-halves again, I give the entire housing a quick tug off the side so that I was holding the whole connector (with wiring-loom) in my hand. This made it easier to insert the two halves again, ensuring tightly inserted - before popping the housing back on.
Started the engine and pressed the switch and `hey presto`, the rear demister was working 100% once and for all.

I then simply popped the plastic panel (along the side) back on.

So basically, if you're having problems with your own demister (rear window heater), check these two connections (boot and front-passenger area), considering WD-40 and if that fails then just by-pass the connection/s in the front and/or boot after first checking your fuse and relay of course...

Good Luck!!
Currently in Dee33's garage:
Renault Laguna RT Sport 1996
Dee33 is offline  
For the best viewing experience please update your browser to Google Chrome