Renault Forums :: Independent Renault forum - View Single Post - Renault Clio 2 - Heater Fan Not Working*FIXED*

View Single Post
post #1 of (permalink) Old 29th January 2010 Thread Starter
Junior Member
Join Date: Jan 2010
Posts: 3
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 2 Times in 1 Post
Renault Clio 2 - Heater Fan Not Working*FIXED*

Well after trauling the internet looking for a fix for my blower not working i stumbled across this site, so armed with common faults i started.

Now my fault was no blower on 1234 so this might not help some of you.

remove driver scuttle panel

unbolt firewall 10ish 10mm bolts

unplug fan connector and check voltage with ignition on and fan switch at 4

If you have 12volts then this is the cheap fix for you.

Remove blower unit (3 10mm bolts) and multiplug (slide red part out) and unclip the plastic clips making sure not to snap them (i broke 2 lol)

Now the unit is in 2 halfs grab the fan part and wiggle the motor unit out.

Pop the metal clips off sides to get to the brushes (2 clips & 2 springs)

If like me you will the wires and brushes destroyed.

Search ebay or google for siemens motor brushes and purchase (12.50 for a pair)

now these will be to big but the graphite is soft as butter so these can be filed down so they slide in witout binding. (might also need to be shortened to around 15mm in length) I used some from a mk1 golf unit so size might vary.

you now need to trim the original wires to 10mm ish in length, also do the same on the new brushes.

Solder the 2 wires together and reassemble.

Plug back up and hey presto working blower.

saving of 195 from stealers for a hours work.

Hope this is of use to someone?


Currently in funk-star's garage:
a lot of mk1 golfs lol
funk-star is offline  
The Following 2 Users Say Thank You to funk-star For This Useful Post:
Peter King (13th March 2013), thisisrobbo (18th January 2014)
  5 Lastest Threads by funk-star
Thread Forum Last Poster Replies Views Last Post
Renault Clio 2 - Heater Fan Not Working*FIXED* Clio Mrfixit143 15 81366 29th January 2010 05:26 PM
Greetings Welcome to RenaultForums scatz 2 971 29th January 2010 04:44 PM
For the best viewing experience please update your browser to Google Chrome