Renault Forums :: Independent Renault forum - View Single Post - Renault Laguna v6 instrument panel problems

View Single Post
post #1 of (permalink) Old 6th July 2006 Thread Starter
Junior Member
Join Date: Jul 2006
Posts: 18
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Renault Laguna v6 instrument panel problems

hi everyone, i have a Laguna Monaco V6 x plate which i love to bits. The only problem i have with it is sometimes the instrument panel goes completley off when driving, (usually more when its really hot outside) and comes back on in a few seconds, it does this randomly and when its hot weather on and off like a yo-yo!!. I get no speedo, rev counter, or anything working in that box! can anyone help me at all what the cause maybe? Iv'e looked in the knowledge base on here and posts there say more than likely a new box needed but could it be a dirty connection anywhere maybe? Would be gratefull if anyone can help?

many thanks

Currently in laguna_monaco's garage:
Laguna 1 V6 Monaco
laguna_monaco is offline  
  5 Lastest Threads by laguna_monaco
Thread Forum Last Poster Replies Views Last Post
ECT Sensor Engines laguna_monaco 3 1480 5th May 2008 09:55 PM
spare parts? Cars & motoring laguna_monaco 2 816 23rd October 2007 04:23 PM
mileage adjustment help Electronics david.susies 3 1070 28th January 2007 05:27 PM
laguna alarm help??? Electronics 1 1083 8th October 2006 08:55 PM
Laguna v6 monaco 2000 model, instrument panel Electronics laguna_monaco 2 1392 4th October 2006 04:31 PM
For the best viewing experience please update your browser to Google Chrome