Renault Forums :: Independent Renault forum - View Single Post - engine just clicking

View Single Post
post #1 of (permalink) Old 7th July 2006 Thread Starter
Junior Member
Join Date: Jul 2006
Posts: 14
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to pupsi
engine just clicking

hi all, this is my first post and i am need of dire help!

i was changing the power cable from my alternator to my battery to bigger cable as i heard it was better when you have ICE in your car like i have.
anyway, i took the bolt that holds the wire out of the alternator and replaced the wire and now my engine clicks just once when i try to start it?
tihnk i shud mention i was a bit of a *** and forgot to disconnect the battery and the end of the power cable coming from the battery and going to the alternator earthed but just seemed to mess up the ring terminal a bit and it didnt earth on the starter motor.
also my battery is fine, runs at 12.8 volts when the engine is off and 14.5 when the engine used to turn on.
hopefully ive given u guys enough information to give me a hand.
Currently in pupsi's garage:
1999 Clio 1.2 Grande
pupsi is offline  
  5 Lastest Threads by pupsi
Thread Forum Last Poster Replies Views Last Post
touch up pen help Bodywork VelSatisfied 1 3477 17th March 2007 03:05 AM
My slightly modded clio My mottah! Lagdti 9 1926 16th March 2007 02:50 PM
My car is lowered but i want lower! Steering and Suspension madnoel10 16 2599 12th March 2007 02:19 AM
engine just clicking Cars & motoring chris m 11 1891 7th July 2006 11:31 AM
For the best viewing experience please update your browser to Google Chrome