Renault Forums :: Independent Renault forum - View Single Post - Renault Clio 2003 - Engines - Loss of power and Warning Light

View Single Post
post #114 of (permalink) Old 1st March 2010
Junior Member
Join Date: Mar 2010
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Renault Clio 2003 - Engines - Loss of power and Warning Light

Am new to the forum but have come across it because my daughter's 1.2 16v 2004 Clio (60k) has displayed classic syptoms of losing power erratically and going into limp home mode, accompanied by permanent service light on and airbag warning light on. Earlier posting meant I have sorted airbag and serice lights by wiggling connector under passenger seats; all of 20 seconds so many thanks. I have booked car into local Renault garge tomorrow and am not at all confident this is going to be an easy or inexpensive journey. I have had an independent mechanic check the wiring loom and although the top of the protective black box just lifts off (why?) there appears to be no damage to the wires. The comments in the forum fill me with dread as the problem appears commonplace but the solution is not at all clear. As with other members I am most concerned for my daughter's safety and a little perplexed that RUK has not addressed this design or manufacturing shortcoming as a priority.

I have greatly enjoyed reading the forum and have learned so much from such informed and helpful comments.
Currently in MJPK's garage:
bmw 320d, mercedes 180
MJPK is offline  
For the best viewing experience please update your browser to Google Chrome