Renault Forums :: Independent Renault forum - View Single Post - Renault Clio 2 - 1.4 16 Valve EML Illuminated*FIXED*

View Single Post
post #11 of (permalink) Old 5th May 2010 Thread Starter
Join Date: Jul 2009
Posts: 48
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 2
Thanked 2 Times in 2 Posts
Re: Warning light on a Y reg clio

Hi all me again with the same problem as when I started this thread. The engine management/warning light for exhaust gas.

It's probably worth mentioning that it was running rough the other week, poor accelleration, hessitation at tickover and loss of power paticularly noticeable at dual carrageway speeds. I changed the air filter and the plugs and its ran fine since, the only noticeable thing was on the plug in number 4 cylinder (the one nearest the gearbox) the spark plug gap had a drop of a clear subsyance in the electrode gap and I assumed that was the cause, not that I'm sure if that has any bearing on the matter and I intend to tell the garage this aswell.

Last time it went into the garage with this fault both the o2 sensors is the exhaust were replaced. I know they've been replaced as I have seen the shiney new sensors in the exhaust. Could they have failed again? Or is is more likely to be the tdc sensor as mentioned previously in this thread or as I thought after the light came back on again could it be the catalitic converter?
Currently in tealc's garage:
2001 renault clio
tealc is offline  
For the best viewing experience please update your browser to Google Chrome