Renault Forums :: Independent Renault forum - View Single Post - Renault - Laguna II - Front springs broken

View Single Post
post #20 of (permalink) Old 5th July 2010
Junior Member
Join Date: Feb 2010
Posts: 10
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 1 Time in 1 Post
Re: Renault - Laguna II - Front springs broken

Originally Posted by Chillman View Post
Yes you most definitely do! My 03 Initaile broke a front right over a hump on Monday morning after an MOT weeks before! Reason: plastic covering on top of spring covers up rusting? Causes rust? Or has some other spurious French reason for being there? If this had broken at speed on the motorway I would not be here now probably! My Polish mechanic has removed these coverings now so we can inspect more carefully! 160 a pair including fitting - Renault? double the amount!?
COR!!!! U woz robbed!! One of mine snapped (n killed a 55.00 tyre recently fitted), while it was parked up after a trip to visit my elderly house-bound Ma. Had to get recovered by the AA (Blue Badge holder & s.posed 2b priority 20mins, took 1.5hrs). Decided to replace both springs, both struts (1 bit sticky) & both ARB link-arms. Took me about 2hrs to sort and only cost me 160.00 n a few cups of coffee n biccies. Pretty easy to do, but watch out for the spring clamps! Borrowed a set off my mate, and the bugger's bit my left thumb badly! Took a chunk outa the skin near the side of my nail about 10mm wide x 2/3mm thick........ooooooowwwwwwwww!! I'm quite competant, but got a knackered back and still managed to sort them. Even with my gammy fum

Good Luck!!

Currently in tazdevil's garage:
2001 'Y' Renault Laguna II 1.9dCi Estate
tazdevil is offline  
For the best viewing experience please update your browser to Google Chrome