Renault Forums :: Independent Renault forum - View Single Post - Paint problems

Thread: Paint problems
View Single Post
post #2 of (permalink) Old 27th August 2010
Platinum member
Oilyrag's Avatar
Join Date: Jan 2006
Posts: 2,875
Nominated 0 Times in 1 Post
Nominated TOTW/F/M Award(s): 1
Thanks: 19
Thanked 28 Times in 27 Posts
Re: Paint problems

Originally Posted by lloydy123 View Post
A couple of months ago i fixed up my rear wheel arches as they were very rusty. I removed the rust, put on primer and then 6 thin layers of colour (red solid paint). It looked great so i didnt bother to T cut or polish it as it loked better than the rest of the car. 2-3 months later the new paint has become very dirty and if any petrol is spilt on the side of the car it melts the new paint.

Any i deas how to correct this? Do i need a coat of clear pain on top? Could it be that Halfords paint is not good quality?
I've not done any paint repairs for a while now but I do know that the new water based paints have to be heated / baked before they are fully dry Not had any problems with Halfords paints in the past but I guess you may have had a faulty can. If you do need a clear laquer then it will usually tell you on the can. Sorry can't be a bit more specific but hope this helps. Kind regards Oily

I am not an alcoholic. Alcoholics go to meetings:D "
Currently in Oilyrag's garage:
59 Vauxhall Zaffira 1.6 Life & 1957 Austin A35
Oilyrag is offline  
For the best viewing experience please update your browser to Google Chrome