Renault Forums :: Independent Renault forum - View Single Post - Renault Scenic II - Access the resistor pack in 5 mins.

View Single Post
post #104 of (permalink) Old 2nd October 2010
Scenic Demon
Scenic Demon's Avatar
Join Date: Jul 2008
Posts: 92
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 1 Time in 1 Post
Re: Renault Scenic II - Access the resistor pack in 5 mins.

just a quick update on mine, using the photo's on here (i can't thank you enough for that aahbarnes ) i've managed to get the resistor pack out this morning, though interestingly it was only held in with one screw, not two which makes me wonder if its been out before under previous ownership.....

anyway, its the purple and brown far wire thats melted in the block connector on mine, and the bit that clips onto the pin was very deformed. I squashed it back together and plugged it back into the resistor pack outside the dash, then switched on and turned the dial just for a second - fan was working on speeds 3 and 4 but not 1 & 2. didn't leave it on cos the resistor pack got hot quite quickly as expected

so i obviously need the new connector and loom and hopefully the new resistor pack will get 1&2 working again too

i've been down to the thieves at the local renault dealer this morning (thankfully no longer Evans Halshaw but not much better.....) on the off chance they keep stock of the part, but the earliest they could supply it was Tuesday so i'm just going to buy online

only problem now is i'm working away Monday to Thursday in France, so my Mrs is left with the car with the dash in pieces and the (not plugged in) resistor pack and block connector hanging out. I'll just have to tell her to leave well alone and do without the fan for another few days

got a big drive coming up at the weekend, so i'm gonna have to try and get it done Thursday night before i go away on Friday... if the parts arrive in time that is

I'll not put my photo's up of progress so far because they're the same as whats already up here, but when i get the new loom etc, i'll do some photo's of that piece cos they're doesn't seem to be any on here yet.

in the meantime, if anyone can help with the process of splicing the new loom on that would be a massive help - i've read on here that its not colour coded and that there is an extra wire - 7 instead of six. while i can match the pin locations up ok to get past the colour coding, i'm a bit nervous about this 7th wire and what to do with it........
Currently in Scenic Demon's garage:
11 Reg Skoda Octavia 1.6 MPi SE and a 2001 Yamaha YZF600R Thundercat
Scenic Demon is offline  
For the best viewing experience please update your browser to Google Chrome