Renault Forums :: Independent Renault forum - View Single Post - Renault Laguna II 1.9Dci - Engines - Hesitation Cured after EGR cleaned

View Single Post
post #175 of (permalink) Old 3rd October 2010
Junior Member
beret's Avatar
Join Date: Jul 2010
Posts: 11
Nominated 0 Times in 1 Post
Nominated TOTW/F/M Award(s): 1
Thanks: 3
Thanked 0 Times in 0 Posts
Send a message via Skype™ to beret
Re: Renault Laguna II 1.9Dci - Engines - Hesitation Cured after EGR cleaned

Originally Posted by metalmickey View Post
HI all. Been trying to find out about the EGR problems on the laguna II . found most things very interesting. but i've got a bit lost. my laguna mkII 51 plate has been starting to run poor and total loss of power sometimes and its been smoking a bit. I took the EGR out and cleaned it (it did come off in two halves) does this mean its broken . Anyway i cleaned it put it back on. But the car still runs the same so i unpluged the EGR. car runs fine with the EGR unpluged. can anybody tell me if i should plug it back in and get a new one. Or could i leave it unpluged. Any help would be very welcome. Thanks all
I did the same, and watch the miracle,car goes better and took me to the desired destination.All that happens after I manually switched off the EGR -valve electronic sensor with a little help of my pencil.After that,the car had good power and acceleration,orange fuel pump lights switch on only 2 times for 5 min.interval and that's it.But my QUESTION is:How long car can go right without problems with unplugged EGR -valve sensor? Thanks in advance anyone for a answer.
Currently in beret's garage:
Renault Laguna II 1.9 dCi 2003
beret is offline  
For the best viewing experience please update your browser to Google Chrome