Renault Forums :: Independent Renault forum - View Single Post - Scenic2 Window Winder fix - with Pix

View Single Post
post #19 of (permalink) Old 3rd October 2010
Scenic Demon
Scenic Demon's Avatar
Join Date: Jul 2008
Posts: 92
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 1 Time in 1 Post
Re: Scenic2 Window Winder fix - with Pix

i have intimate knowledge of the window winders on my scenic

the first one to go was rear passenger side, when i took the door apart i found the plastic slider in bits at the bottom of the door - it had obviously failed before, cos it had been plastic welded back together, that time i managed to find a replacement slider on ebay and the wires were ok so it was easy enough to put back together and i've had no bother with it since. for the poster above, sorry i don't have any pics, but i remember it being reasonably straight forward to work out and not much different from the front window photo's earlier in this thread. sorry i know that doesn't help much

the second one to go was the drivers door, again, the slider had broken, this time it had mangled the wires too. back onto ebay , got another new slider and also a kit for cutting my own wires to length with stops and stuff, i struggled to get the wires to the exact length cos my old ones were so mangled, and when i put it back together it showed cos they weren't really tensioned enough, so it was no suprise when it failed again a few months later.

this time, the slider was ok, just one of the wire stops had sheared off, so i bought another kit off ebay and made up a new wire, this time i got the lengths more accurate, and it all went together well and looked good

so i'm quite disappointed that this week, the drivers door has failed for the THIRD time. i haven't taken the door panels off again yet (only cos my heater resistor pack and block connector are my number one priority at the minute) but i'm guessing its the stopper off the wire again

so i'm wondering what i'm doing wrong now. i could buy another kit off ebay and make some more wires up, but i don't want to be doing it for the 4th time in another 3 months.

the only thing I can think, is either i made the tension too tight this time, or i didn't do a good job on the heating process when i hardened the adhesive stuff

anyone else used these wire kits off ebay ? - link below
Currently in Scenic Demon's garage:
11 Reg Skoda Octavia 1.6 MPi SE and a 2001 Yamaha YZF600R Thundercat
Scenic Demon is offline  
For the best viewing experience please update your browser to Google Chrome