Renault Forums :: Independent Renault forum - View Single Post - Renault Scenic II - Access the resistor pack in 5 mins.

View Single Post
post #116 of (permalink) Old 8th November 2010
Junior Member
Join Date: May 2010
Posts: 11
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 3
Thanked 0 Times in 0 Posts
Re: Renault Scenic II - Access the resistor pack in 5 mins.

Originally Posted by shweeney View Post
hi folks,

the fan on our 05 Scenic II has recently gone completely - not working on any setting. Its the model with climate control - if I manually turn on the Aircon I can hear it clicking on but there's no fan to blow it and we can't demist the windows etc (btw anyone having the same problem I highly recommend a product called Rain-X AntiFog that Halfords sell).

anyway, took to the local Renault centre and they are saying it needs a new "Rheostat" - is this the same issue people are reporting here? I've been quoted 500 to fix it, which after having to replace the handbrake motor earlier in the year is a real kick in the teeth.
cracked open the dash as per aahbarnes instructions this evening - I was able to get the wiring loom and plug out but can't see anything else there that I can remove and no sign of melting on the plug. There is another loom and plug at the top of same area - guess the climate control setup is different. Has anyone with climate control successfully fixed this problem themselves?
shweeney is offline  
For the best viewing experience please update your browser to Google Chrome