Renault Forums :: Independent Renault forum - View Single Post - Renault Laguna 2 - 1.8 16v Throttle Problem*FIXED*

View Single Post
post #66 of (permalink) Old 10th November 2010
Junior Member
Join Date: Aug 2009
Posts: 3
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 3 Times in 2 Posts
Re: Renault Laguna 2 - 1.8 16v Throttle Problem*FIXED*

Hopefully may have a fix and method of testing
now done three of these all with the same fault.

Not throttle body , harness, ecu or position switch

As with the previous posts the fault is in the ecu wiring. The faults I have found are with the computer earth in the top plug of the ecu
Remove battery box and ecu
Testing check continuity from the throttle body two light orange wires and four grey to the centre plug on the ecu to do this you will need to remove the plug wire tie bands on the plug backs, if no continuity repair other wise follow on

remove plug backs pull computer to front of car so you can reconect battery.
start car and run up to engine is warm by doing this you open the throttle body remove battery earth to clear memory in ecu and reconect battery

put key in to ignition and you should now be able to here the throttle body . the sound should be a low buzzing noise as the ecu holds the body open due to engine being warm.
as you now have access to the ecu plugs if you move them from side to side you will here the throttle body motor moving in and out and you have now found the fault
the faults I have found relate to the top plug on the ecu the two black earth wires for the computer.

to clean there is no easy way to clean the conection what I do is remove the rubber seal around the plug to allow more movement in the plug using either electomex or WD40 liberally spray conectors and keep working form side to side unpluging and repluging, on occasions I
have had to clean and waggle the plugs for about 15 min until you dont get the trottle motor moving in and out and hey presto you have cured your bad connections to the computer and dont get the throttle body error so to recap the injection light and throtle body error appears to flag up due to poor computer earth conections

hope this will help a lot of disguntled Laguna owners

Aphelion RTE
Aphelion is offline  
The Following 2 Users Say Thank You to Aphelion For This Useful Post:
longleigh (30th October 2014), Thameside (31st August 2014)
For the best viewing experience please update your browser to Google Chrome