Renault Forums :: Independent Renault forum - View Single Post - Renault Clio 2003 - Engines - Loss of power and Warning Light

View Single Post
post #130 of (permalink) Old 27th November 2010
Junior Member
Join Date: Nov 2010
Posts: 3
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Renault Clio 2003 - Engines - Loss of power and Warning Light

This problem has just started on my 1.2 16V Dynamique Clio at 76,000 miles. The orange wiggly warning light with loss of power and maximum of 40mph speed. However, I have additional activities which all seem on the electrical side. When I indicate left, my rear windscreen wiper comes on. When I brake my fog light indicator comes on the dashboard, my windscreen water jets won't spray out, and the other night, after the warning light and loss of power came on I pulled over and turned off the engine, and the dashboard then did the maddest thing, every light for everything started flashing like somesort of spaceship. Has this happened to anyone. I have taken it for 2 computer readings at Renault garages (abroad they don't charge to do this) and both said the same thing - 2 faults showing up (1 is a sensor, i don't know which). The first garage wiped the fault and told me it may have just been a fault in the computer memory, so if it doesn't come back on don't worry. Unfortunately it popped on again on an Italy motorway. I have gone through the whole thread reading everything and I have a list of 11 things it could be from everyone's advice. I'm feeling overwhelmed and don't know where to start.
I am guessing with all the other electrical wierd things going on its something to do with wires? Any one have any advice on that.
Many thanks.
Currently in cazerra's garage:
Renault Clio 1.2 16V Dynamique 2003
cazerra is offline  
For the best viewing experience please update your browser to Google Chrome