Renault Forums :: Independent Renault forum - View Single Post - Renault Clio 2003 - Engines - Loss of power and Warning Light

View Single Post
post #131 of (permalink) Old 13th December 2010
spud turbo 192
Junior Member
spud turbo 192's Avatar
Join Date: Dec 2010
Posts: 9
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 2
Thanked 0 Times in 0 Posts
Exclamation Re: Renault Clio 2003 - Engines - Loss of power and Warning Light

hi there ive had all the problems you seem to mention,the orange light and the limp home mode,ive got a very good knowledge of cars so after carefull thought and trawling through simalar problems on here replaced all the obvious things i thought were neccesary ie full wiring loom, tdc sensor,oxygen sensor, map sensor , throttle body , coil pack,and the black box related to the throttle peddle,i forget the name,like a sender unit,so 300 pounds later and geuss what? no change exactly the same problem,it happens every time i take the car out at some point,i found that taking off the air box and spraing around a quarter tin of carb cleaner in while engine is running seems to sort it but only for a short while,then its back out of nowhere,im not daft and neither are the people on these forums who have these problems and who know anything about engines,,its nothing to do with anything ive replaced renault dont even know what it is and they made the damn car,i put it down to far to many electrical components on the car that are far to close to each other,if u ask me they interact and get the wrong signals so dont know what to do and the ecu takes over and puts the vehicle into limp mode
Currently in spud turbo 192's garage:
2002 clio
spud turbo 192 is offline  
For the best viewing experience please update your browser to Google Chrome