Renault Forums :: Independent Renault forum - View Single Post - bad squeaking from rear passenger side

View Single Post
post #1 of (permalink) Old 10th February 2011 Thread Starter
Junior Member
Join Date: Oct 2010
Posts: 4
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
bad squeaking from rear passenger side

Hi everyone,
I have a megane 1.6 alize on a v plate and i recently had the rear brakes replaced due to the old ones sticking on,but, a day after having the new brakes fitted,there was a squeaking noise coming from the back of the car,passenger rear side.This squeaking noise is pretty loud and is very constant happening whether your in 1st/2nd gear or doing 60mph and especially going round corners and when you pull off! It seems as if its getting worse all the time?
This has been going on for 2 weeks now,and before i take it back to the garage i was wondering if anyone as any experience of this or any ideas of what it could be,giving me some ammo,as i have no knowledge of car maintenence,thanks in advance.
Currently in marmar's garage:
1999 megane alize 1.6
marmar is offline  
  5 Lastest Threads by marmar
Thread Forum Last Poster Replies Views Last Post
bad squeaking from rear passenger side Cars & motoring madnoel10 3 1855 10th February 2011 03:28 PM
passenger rear side squeaking badly Engines marmar 0 808 10th February 2011 03:08 PM
problem starting my megane after a drive Electronics cph1984 3 873 27th October 2010 12:29 PM
For the best viewing experience please update your browser to Google Chrome