Renault Forums :: Independent Renault forum - View Single Post - Renault Clio 2003 - Engines - Loss of power and Warning Light

View Single Post
post #148 of (permalink) Old 23rd February 2011
Junior Member
Join Date: Nov 2010
Posts: 3
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Cool Re: Renault Clio 2003 - Engines - Loss of power and Warning Light

The loss of power and the wiggly warning light coming on has been happening to me for 6months in my 2003 Dynamique Clio.
I have been following the advice posted here on the forum as I cannot afford to give Renault £400-£500 each visit, thus i've been limping along for 6 months. Dangerous but I have no choice.
A few weeks ago I got under the drivers seat (as advised somewhere in this thread and wiggled and wiggled all the wires underneath. There are loads under there. Unbelievably, and I hope this does not jinx it, the warning light has not come on since. And considering it was coming on at least once a day for 6 months, this is a big change.
So wires, electrical short, something like that must be the answer for my Clio. However, I still have lots of odd electrical things going on. When I brake the back window wiper comes on and so does the fog lights. When I indicate the brakes flash with the indicator. I am now taking it to a local garage for them to focus on wiring and fingers crossed.
Currently in cazerra's garage:
Renault Clio 1.2 16V Dynamique 2003
cazerra is offline  
For the best viewing experience please update your browser to Google Chrome