Renault Forums :: Independent Renault forum - View Single Post - Renault Clio 2003 - Engines - Loss of power and Warning Light

View Single Post
post #149 of (permalink) Old 2nd March 2011
graham reekie
Junior Member
Join Date: Feb 2011
Posts: 2
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 2
Thanked 0 Times in 0 Posts
Re: Renault Clio 2003 - Engines - Loss of power and Warning Light

Ihave a Renault Clio 2003 1.2 16v, I have similar problem with loss of power did all the usual things changed the coil pac T.D.C sensor ect. Didn't get any joy, being a diesel mechanic my knowledge with cars is limited. However im very determind. i bought a cheep diagnostic tool on Ebay thought it might help point me in the right direction.
It came up with a faulty map sensor , thinking it would be inexpensive i went along to my local Renault dealer, i was wrong, 96 quid you could have knocked me down with a feather. I bought the part with some reluctance, fitted it too my car, still no joy and 96 quid poorer.
I have since registered with Renault forum, it's been very helpfull reading other peoples expieriances.
I think i have found my problem at the E.C.U there is some sort of bracket below the plug on the o/s don't know what its purpose is but it is loose. I removed the plug to find that it has been chaffing the wires, one of which was almost broken, surprise surprise the wire that connects via the plug on the map sensor . Im fairly confident this is my problem hope it helps others.
Currently in graham reekie's garage:
2003 Clio 1.2 16v
graham reekie is offline  
For the best viewing experience please update your browser to Google Chrome