Renault Forums :: Independent Renault forum - View Single Post - Renault Clio 2003 - Engines - Loss of power and Warning Light

View Single Post
post #171 of (permalink) Old 16th May 2011
The Professor
Junior Member
Join Date: Apr 2011
Posts: 17
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 1 Time in 1 Post
Re: Renault Clio 2003 - Engines - Loss of power and Warning Light

Originally Posted by kris8388 View Post
I have the exact same problem and i too can not seem to find a solution to this problem. Everyone seems to have a different 'solution' but nothing seem to work.
I know how you feel! So far I've:
  • Changed the engine wiring loom - there was slight fretting damage around the ECU plug as expected
  • Changed the MAP sensor
  • Changed the crank sensor
  • Changed the coil pack
  • Checked the earthing strap
  • Checked the operation of the throttle - it seems to be logical based on the readings I get
  • Cleaned the throttle body - it was clean anyway
  • Logged the actions of the O2 sensors.
I now think something is causing this engine to over fuel and then suddenly 'lose control of itself', so I will check the coolant temperature sensor next.
I really need to log pretty much everything that's going on and get a freeze-frame when the electrical warning light comes on. I just can't find out what's triggering it and causing the rough running and cut-out. I don't know that I've got enough functionality to do that, so I'm tempted to book it into the local independent, who has the Renault Clip package. They'll run a diagnostic for 45.20 + VAT
The Professor is offline  
For the best viewing experience please update your browser to Google Chrome