Renault Forums :: Independent Renault forum - View Single Post - Renault Clio 2003 - Engines - Loss of power and Warning Light

View Single Post
post #187 of (permalink) Old 29th June 2011
Diamond member
JimC64's Avatar
Join Date: Feb 2010
Posts: 79
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 8
Thanked 16 Times in 16 Posts
Re: Renault Clio 2003 - Engines - Loss of power and Warning Light

UPDATE - As before ALL electrical connections were cleaned and checked for a positive fit.
No chafing of the wires as far as we could tell.
Battery cables removed and connections wire brushed, reconnected and smeared with grease to ensure positive earth.
New spark plugs fitted.
Throttle body removed and cleaned - this was quite badly gunked up according to the mechanic and was cleaned thoroughly and replaced ensuring a good seal. He also said he cleaned the breather connections?
Cost - 40

Before - acceleration seemed almost a little hesitant and it could cut out showing electrical warning signs with severe loss of power at any moment. Cut out on Monday, Tuesday and Wednesday.

After - the electrical + battery terminals cleaned on Friday last week and hasn't cut out again since, touch wood!
Acceleration seems much improved and more responsive in all gears, just seems more lively throughout.

Possibly too early too tell, but seems resolved at the present time.

I will of course return and repost if the problems re occur


Currently in JimC64's garage:
MY2007 Audi A6 3.0 Tdi SE Qauttro 176bhp Stratos Blue, Front & Rear park assist, Comms Pack High, Sline grille badge, 19" RS4 alloys, Rear tints, Dipped bulbs 80W, Mainbeams 100W, Foglights 100W, Number plate bulb LED's, Interior bulb LED's, First Aid Kit, Bootliner, Mudflaps front & rear, Calipers & hubs painted. MY2005 VW Passat 3.9 Tdi Highline
JimC64 is offline  
For the best viewing experience please update your browser to Google Chrome