Renault Forums :: Independent Renault forum - View Single Post - Renault Megane - Engines - Chugging Megane - Toxic Fume Filter

View Single Post
post #38 of (permalink) Old 4th July 2011
Junior Member
Join Date: Jul 2011
Posts: 8
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Renault Megane - Engines - Chugging Megane - Toxic Fume Filter

Hi All,

Have lurked on this site in the past looking for solutions to problems with my Megane over the past two years and now I need help!

I think I am having a similar problem. Have a 55 plate Megane 1.4.

Just coming back from a long trip last Tuesday and there was a knocking noise that seemed to be coming from a belt. There was also a sudden loss of power that was not linked to any gear selection it just happened. Would be going along comfortably and revs would disappear.

Had timing belt replaced as it was due, a friend who used to teach stripping & repairing engines had a look and blew out the carb with some redex and told me to go for a motorway blast.

Problem went away for a day and is now back!

Had a service in May alongside MOT. Nothing reported then, nor after belt change. No warning lights accompanying this problem!

Only things left that were recommended after service are replace spark plugs! They were rated as Amber - could this be the problem?

Any help gratefully recieved!
Currently in Garfster2609's garage:
Megane 1.4 Expression 55 Plate
Garfster2609 is offline  
For the best viewing experience please update your browser to Google Chrome