Renault Forums :: Independent Renault forum - View Single Post - CD Changer .... driving me MAD

View Single Post
post #6 of (permalink) Old 12th September 2006
Platinum member
Horatio's Avatar
Join Date: Jul 2005
Posts: 6,475
Nominated 0 Times in 7 Posts
Nominated TOTW/F/M Award(s): 8
Thanks: 0
Thanked 95 Times in 64 Posts
It's my experience that Renault dealers will do their level best to fob you off when it comes to stereo faults. I've had a few niggles with my Renault factory stereos over the years, but their answer is invariably "we can send it away to be looked at, but you'll have no stereo for a few weeks." In most cases, the fault wasn't serious enough to justify being without tunes for ages. They knew that, and they milked it I'm sure.

I've had the Alpine changer in both my previous L2 and the L1 before it, and it's been a cracking player on both cars. I don't ever recall either of them skipping, though the L1 one had an interesting quirk whereby disc 2 always started from the beginning of track 1 whenever you turned on the ignition. Both players have handled both original discs and CD-R. Neither was happy with CD-RW, but I pretty much expected that.

Prior to that, I had a Kenwood unit that I originally bought for my Mazda but later stuck in my first L1. That was an awful unit and skipped from day one. Worse still, it tended to scratch the discs as it loaded them in and out of the magazine, which made the skipping progressively worse. Of course this pre-dates me having a CD writer (it wouldn't play most brands of CD-R anyway) and so it meant that my original CDs were getting damaged.
Currently in Horatio's garage:
2010 Laguna III Initiale.
Horatio is offline  
For the best viewing experience please update your browser to Google Chrome