Renault Forums :: Independent Renault forum - View Single Post - Renault Scenic II - Access the resistor pack in 5 mins.

View Single Post
post #196 of (permalink) Old 21st September 2011
paperboy1's Avatar
Join Date: Jun 2007
Posts: 35
Nominated 1 Time in 1 Post
TOTW/F/M Award(s): 0
Thanks: 4
Thanked 1 Time in 1 Post
Re: Renault Scenic II - Access the resistor pack in 5 mins.

Hi all,
My 2004 Scenic also has problems with the blowers in that speed 1 and 3 work only. I have followed the instructions and pics on this forum (very impressive and informative) and removed the connector block from the resistor. I found that parts of the block have melted which I assume has caused the speeds 2 and 4 to fail on my blowers.
I haven't removed the resistor as yet but by shining a torch down the hole in the dash I saw some of the pins need a bit of rubbing down.
I contacted Renault who told me a complete fix was around 260 and the parts only (resistor and loom) was 120. Interestingly, he told me the parts were always in stock after I asked him about availability...hmmmm!
I've put this off for 3 years now so I'm going to bite the bullet and buy the kit and fix it myself.
The original wires are all colour coded so even if you snip them all at the same time you cant go wrong. Will update you at a later date.
One question though is it loose wires in the block which are arcing and then melting the block or is it loose connections between the block itself and the pins on the resistor arcing and doing the melting. I ask this because I'm considering just buying the loom. Any thoughts?
Lastly to answer a previous question regarding how the resistor is attached under the dash - I found only 1 screw to the near side (although there should be 2).
Have attached (hopefully) pics of my damaged connector.
Cheers Stevie.
Attached Thumbnails
Click image for larger version

Name:	Melted block end.jpg
Views:	353
Size:	45.9 KB
ID:	13953   Click image for larger version

Name:	Melted block side.jpg
Views:	358
Size:	51.7 KB
ID:	13954  
Currently in paperboy1's garage:
Scenic II 1.4 16V

Last edited by HeatherJ; 21st September 2011 at 06:47 PM. Reason: Cant name and shame... sorry
paperboy1 is offline  
For the best viewing experience please update your browser to Google Chrome