Renault Forums :: Independent Renault forum - View Single Post - Engine/fuel Pressure sensor

View Single Post
post #1 of (permalink) Old 13th September 2006 Thread Starter
Diamond member
Join Date: Mar 2006
Posts: 101
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 1 Time in 1 Post
Engine/fuel Pressure sensor

I have just bought a tuning box for my 2005 Laguna 1.9DCi (facelift)!

The problem I am havin is that the unit is to be placed between the engine/fuel pressure plug and the engine. Basic terms.....the engine/fuel pressure sensor plug, goes into one end of the box then the other end then plugs into the engine where the original pressure sensor plug goes. (you follow I hope )

Anyway I done just this with the only plug in the area indicated in the fitting diagram but it appears to be wrong. When I try to start the car it just ticks over. Then I get the warning message on the dash stating "Check Injection System"??

If I take out the box then the car starts perfect again.

I am guessing the plug relates to the injection system and isn't the right one. The fitting diagram shows a pre-facelift engine so I don't know whether there's been changes in location for the one I am looking for?

I have contacted the company regards help in fitting but being out of office ours they haven't replied yet and I am desperate to get it fitted after experiencing the gains in other Laguna's with the box fitted

Help appriciated or any photo's to help me along
Currently in Ne1l's garage:
2005 Renault Laguna 1.9Dci
Ne1l is offline  
  5 Lastest Threads by Ne1l
Thread Forum Last Poster Replies Views Last Post
Laguna - 1.9DCi Oil Grade Engines coggsy 6 15117 26th January 2008 03:08 PM
Laguna - Oil Leak Engines Nikko1 15 8530 26th January 2008 03:00 PM
Front Bumper Re-spray Bodywork stef123 1 1492 20th January 2008 02:40 PM
Single DIN to Double DIN Interiors Horatio 3 2949 9th January 2008 08:07 PM
Recommend me some bulbs Electronics jack daniels 10 2230 28th December 2007 03:38 PM
For the best viewing experience please update your browser to Google Chrome