Renault Forums :: Independent Renault forum - View Single Post - A few questions regarding clio MKII

View Single Post
post #1 of (permalink) Old 26th September 2011 Thread Starter
Junior Member
Join Date: Jun 2011
Posts: 4
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
A few questions regarding clio MKII

Hi guys, I recently bought a 2001 clio 1.4 16v and I have a few questions about it.

Firstly I can't find any record of a timing belt replacement, they're meant to be done at 72k or 5 years I believe. The car hasn't done 72k yet but it should have had 2 new cam belts by now. Is there anyway I can tell how warn/old the current one is and is the quote of 650~ for new cam belt and water pump reasonable (I got a quote from renault because I believe it needs renault spec locking pins)

Next the car is a pain to pull away in, you really have to rev it to stop it stalling and if it's cold the revs drop quite a lot when you touch the throttle and it comes of it's cold idle speed. 2 other people who drove this car have similar problems but like me they have been driving diesels for quote a while. I could just be being a whiny ***** as this is the first petrol car I've driven, but I would still like to know of any common faults which may cause this.

And finally how stable should the temp guage be, I noticed on the ph2 model it never budged from horizontal but on mine it's often below that and when idling/traffic/parking it rises slightly. Not enough for a fan or anything but I thought I'd mention it as the ph2 was pretty much constantly the same once it was up to temperature.

Thanks for any replies guys.
Owen.C is offline  
  5 Lastest Threads by Owen.C
Thread Forum Last Poster Replies Views Last Post
A few questions regarding clio MKII Cars & motoring Owen.C 3 1060 26th September 2011 01:06 AM
For the best viewing experience please update your browser to Google Chrome