Renault Forums :: Independent Renault forum - View Single Post - brakes - help !!!

View Single Post
post #1 of (permalink) Old 10th October 2011 Thread Starter
Junior Member
Join Date: Aug 2011
Posts: 17
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 1 Time in 1 Post
brakes - help !!!

Hi Everyone, Looking for some information,

I have a 2005 Clio and have used the same garage since I got the car 3 years ago. Never had any real issues with the car until now.
I recently put the car into get the brakes and some other work done as the car was pulling to the left and I could see the discs looked pretty worn, I got the car back and funnily enough it was no longer pulling to the left but now has a major pull to the right, I took the car straight back to the garage and they test drove it and confirmed there was a fault but (here is the bit I need help with) they can not find a fault ???
I have had the front discs, pads, calipers and flexi hoses changed over for new ones and also we have had the back brakes done aswell. The car has been back several times and they dont know what to do with it ??

also one problem which I have noticed is that the drivers side disc only has some small wear on it ? front the top of the disc on about half way down it is shiny , which I think means the pads are touching it but then it is starting to rust as if the pads are not touching??

Also when driving home tonight all off a sudden I was getting a major grinding noise which seemed to be coming from the front and back?? and then all of a sudden I felt as if the brakes were very spongy and when I stopped I noticed that my handbrake had a lot more movement than it did this morning, It was 3/4 clicks but now it goes away past that prob near to 10/12 clicks??

Sorry I know this is a long one but any info would be greatly appreciated

Thank you all
Currently in cglasgow82's garage:
Megane 2005 1.6 16v
cglasgow82 is offline  
  5 Lastest Threads by cglasgow82
Thread Forum Last Poster Replies Views Last Post
Upgrading brakes Brakes/Hubs cglasgow82 2 595 28th March 2014 10:51 PM
Permiwrap Bodywork cglasgow82 0 809 26th March 2014 01:28 AM
Bolt destroyed :( :( Help Please Wheels & tyres mickeybo 4 1025 22nd July 2013 07:15 PM
Megane Fuel Pump Engines whizzy41 1 867 25th March 2013 11:39 PM
For the best viewing experience please update your browser to Google Chrome