Renault Forums :: Independent Renault forum - View Single Post - Renault Clio 2003 - Engines - Loss of power and Warning Light

View Single Post
post #207 of (permalink) Old 13th October 2011
Junior Member
Join Date: Oct 2011
Posts: 14
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 0 Times in 0 Posts
Re: Renault Clio 2003 - Engines - Loss of power and Warning Light

My first post too and all I can say is thank God for such a great platform!!! It seems we have a similar issue. The only difference I can see is that my vehicle begins "juddering" before the loss of acceleration and I don't get a warning light now. I did initially, the service light and air bag light came on but i think that was coincidental as it hasn't happened more than a few times.

I have an auto 1.6 so im not sure if that makes any difference. Its just passed its MOT last week and had on top, oil change, plugs, air and oil filters. I am toying with changing the HT leads, coil and fuel filter to see if that helps eliminate the problem. Does anyone have any thoughts on this?? Im getting paranoid now about going out in traffic as I keep breaking down on roundabouts etc when the car is in creep mode! The fault, whatever it is, does appear to clear eventually, its like it has a cough, clears its lungs and runs a marathon(literally flies) until the next time we slow down in traffic etc. I have also on 2 occasions noticed a slight burning smell associated with this fault!!

Please HELP!!!!! Louise
Currently in opsres1's garage:
1999 T reg Clio 1.6 auto
opsres1 is offline  
For the best viewing experience please update your browser to Google Chrome