Renault Forums :: Independent Renault forum - View Single Post - Renault Laguna II - Phase 1 - Engines - Turbo Diesel Engine Problems

View Single Post
post #98 of (permalink) Old 30th October 2011
Junior Member
Join Date: Oct 2011
Posts: 8
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Renault Laguna II - Phase 1 - Engines - Turbo Diesel Engine Problems

Originally Posted by Tolak View Post
If it was going OK, then chances are it still wants to.
Just a matter of getting control to it.
And it is all too easy to knock one of these pipes without noticing, or pull on one as you reach around the back of the manifold, so that the connection is poor and you have a vacuum leak (or, more accurately, an air leak into the vacuum system)

But don't forget that the pressure sensor downstream of the intercooler will have been disturbed (including wiring) when the intercooler was changed, so there may be a latent failure from that effort.
in my earlier post. I said about the driving it and then lost all power went and guessed the turbo had gone . I remember seeing the (heater plugs electronic fault indicator light) came on. thats when i drove it home and parked it up until i could afford to get turbo done. now that i have had all the work done its never came back on whilst driving. does this help at all . Just been down the road and sounds rough as old boots. Do you think the turbo is not set right i'm just geussing as its doing my head in now. Its great car mint condition just a shame its not running right. Please someone help thanks
Currently in muddymess's garage:
laguna 1.9 dci
muddymess is offline  
For the best viewing experience please update your browser to Google Chrome