Renault Forums :: Independent Renault forum - View Single Post - What's the scariest car failure you've had while driving?

View Single Post
post #39 of (permalink) Old 1st November 2011 Thread Starter
Diamond member
BillaBongBaby's Avatar
Join Date: Oct 2011
Posts: 869
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 46
Thanked 34 Times in 29 Posts
Re: What's the scariest car failure you've had while driving?

Continuing thanks to everyone for adding their tales of motoring 'mishaps & near misses'.
I knew there would be varied and stomach churning accounts.

Please do continue.

Here's another of mine from the days (only 3 yrs ago) when I had my Vectra 1.8 estate...
that went through each and everyone of it's multitude of sensors a couple of times at leastin the 5 yrs I owned it (notice it and not 'her'!!)

It's fave sensor to go was always the camshaft sensor! We had it replaced 4 times in 5 yrs.
The worst thing was it always caused the car to stall (no warning) ..... no matter whether stationary or actually moving!

It always always gave out just as I took off into a gap on a particularly vicious 3 lane roundabout here in London ..... !

Needless to say, I was very very good at re-starting the engine while still moving - had to - 9 times out of 10 there'd be a bus bearing down on me!

No more Vauxhalls for me!
Currently in BillaBongBaby's garage:
03 CLIO 80 Billabong 1.5DCi special edition in metallic Blue or is it Green?
BillaBongBaby is offline  
For the best viewing experience please update your browser to Google Chrome