Renault Forums :: Independent Renault forum - View Single Post - Renault Laguna 2 - 1.9dCi No Turbo Boost/Limp Mode*FIXED*

View Single Post
post #2 of (permalink) Old 26th November 2011
Veteran Member
Technical Supremo
Lagdti's Avatar
Join Date: Dec 2005
Posts: 40,429
Nominated 2 Times in 20 Posts
Nominated TOTW/F/M Award(s): 18
Thanks: 149
Thanked 1,103 Times in 942 Posts
Re: laguna II 1.dci - what to do next?

Hello and welcome to the forum.

Ideally you need to have the fault codes checked and the live data read from the ECU ,but getting that done tomorrow is unlikely to happen.

As it's going into limp mode it's more than likely a turbo boost pressure fault,either over-boost,under-boost,or a sensor telling the ECU that either is happening misleadingly.

I'd start by checking the vacuum pipes to the boost controller and the boost pressure sensor.They can fill up with carbon and cause a similar fault.It would also be worth checking for boost pressure leaks around the pipe work between the turbo ,intercooler and inlet manifold.Check the intercooler it's self too,early ones had a tendency to split/expand although your car is later and should have the updated intercooler fitted to prevent this from happening.

The fact that there is a damaged thread on the EGR valve isn't ideal,but I doubt that enough boost pressure is leaking from the joint to cause any problems,the other two bolts should hold it in place perfectly fine.
Currently in Lagdti's garage:
2004 Saab 9-5 HOT Aero and a 2001 Audi A3 1.8 Turbo
Lagdti is offline  
The Following 2 Users Say Thank You to Lagdti For This Useful Post:
andyboro (27th November 2011), Laciotat (24th March 2013)
For the best viewing experience please update your browser to Google Chrome