Renault Forums :: Independent Renault forum - View Single Post - Renault Clio - Electronics - Installing an ICE for clio MK2

View Single Post
post #17 of (permalink) Old 22nd September 2006
Junior Member
Join Date: Sep 2005
Posts: 26
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by Benny
There's a rubber grommit on the right hand side of the bulkhead that you can pull a power cable through. My other half has 8AWG in her Clio, although 4AWG would be better if you can fit it.

If you're going with a subwoofer, I wouldn't bother with 6x9s. Go with a decent 4-channel amplifier, bridge the rear channels for the sub and use the front two channels for the front speakers. Believe me - good front speakers with enough amplified power will give a far more pleasing sound than using ovals in the back. Much more dynamic. Plus, if you shelf-mount 6x9s, they need to be isolated from the boot airspace, or they can be damaged by the use of a subwoofer.

I too made the mistake with the HU and killed the central locking switch, luckily we fished the connector out with some tweezers and reattached it!

In the end we went for an Arc Audio Arc-8D2, wired to four ohms, in a 0.35 cubic foot sealed box. It's getting about 160w RMS from a Mac Audio amplifier and it really does thump nicely. Doesn't drop too well below about 40Hz, but it adds a nice warmth to the music and it's small enough to leave some boot space.

Click Me!
Click Me Too!


Is the grommet in the footwell in the drivers side of the car? Ive lifted the passengers side carpet up and found a black cover but its hard plastic and wont come up.

cheers for any advice aky
Currently in aky's garage:
2006 Ford fiesta zetec climate
aky is offline  
For the best viewing experience please update your browser to Google Chrome