Renault Forums :: Independent Renault forum - View Single Post - Laguna II - ABS not working but no warning lights ?

View Single Post
post #69 of (permalink) Old 26th December 2011
trickyd400's Avatar
Join Date: Oct 2011
Posts: 48
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 4
Thanked 4 Times in 4 Posts
Re: Laguna II - ABS not working but no warning lights ?

Yes I took the bumper off completely, I have the undertray off at the moment too. I repainted the grazed trim in the n/s of the bumper as it is easier to remove it without damage when the bumper is off.


I touched in the scratches on the rearbumper which is the same colour at the same time. Also I replaced a missing trim from the headlight washer jet (thanks ebay )

OK down to business, bumper removed, as per insrtuctions for headlight washer replacement in another thread.

So wheel is off, and inner wheel arch removed (sunroof drainage blockage issue now resolved too) I removed the horns one 13mm bolt and one plug.

then the small metal bash plate, 2 more bolts

also removed the inner splash guard, 2 plasic 1/4 turn trim clips along its lower edge and it clips onto 2 uprights

You will notice the gravel drive, which is a pain in the a***e, so I always keep large cardboard boxes (flattened) to work on, saves my aging knees!
Next I undid 2 of the ABS pump bracket bolts with a 10mm spanner and a 13mm socket:
You can just see the head of the bolt to the left of the ABS pump connector (blue & yellow)

and this bolt:

The bracket is now held on by one more fixing, but enough movement is possible to extricate the ECU . Next undo the 2 T25 torx srews that hold the ECU to the pump body: one through this hole:

the other with a 1/4" drive and bit adapter: or 3/8" T25 bit just fits...

Un plug the ABS blue plug and ease off the ECU and reassemble.

I had previously plugged my new ECU in and turned the ignition on just to be sure that the ABS lights went out as required , which they did.
I was also happier doing this as the valve block arrived with all the brake pipe ports open with obvious signs of dirt ingress...
Finally replacement nearly new discs and new pads:
Currently in trickyd400's garage:
2001 Renault Laguna II 1.9dCi Dynamique Estate, Ford Fiesta Mk6 1.25 Style, CBR400RR, Beta Zero Gara- now stolen!!! GRRRR!!
trickyd400 is offline  
For the best viewing experience please update your browser to Google Chrome