Renault Forums :: Independent Renault forum - View Single Post - Renault Clio 2003 - Engines - Loss of power and Warning Light

View Single Post
post #220 of (permalink) Old 23rd February 2012
Inveterate Bodger
Join Date: Mar 2009
Posts: 786
Nominated 0 Times in 3 Posts
Nominated TOTW/F/M Award(s): 1
Thanks: 48
Thanked 45 Times in 43 Posts
Re: Renault Clio 2003 - Engines - Loss of power and Warning Light

Originally Posted by ash123456 View Post
Driving down the motorway then clio 1.2 1999 stutters if my foot remains on the accelerator and car continues to stutter along, losing power as the rev counter drops... If i decelerate i can remain at around 50mph-60mph and no stutter noise - but i want more out of the car!
Even pulling away in 1st it sometimes stutters - progressively getting worse :loser:
any ideas of how to get rid of this annoyance!?
Thanks in advance.
Good chance it's the coils - what happens if you rev it harder i.e. use a lower gear for the same speeds?

I couldn't sustain any kind of decent speed in top in my 1.6 megane when they started to go unless i was really racing ... had to use 3rd and 4th at low-medium motorway speeds, otherwise it basically lost two cylinders at low rpm/wide throttle and those two didn't run ever so well themselves... Starting off required you to thrash it and feather the clutch like your granny would navigating a car park in her metro.
Currently in tahrey's garage:
Honda CG125, Scott Voltage MX5, dirt, lots of random bottles and tools, porktastic Clio III DCi, dodgy shelves...
tahrey is offline  
For the best viewing experience please update your browser to Google Chrome