Renault Forums :: Independent Renault forum - View Single Post - Megane dynamic 2004 automatic starting problems

View Single Post
post #1 of (permalink) Old 18th March 2012 Thread Starter
Junior Member
Join Date: Mar 2012
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Megane dynamic 2004 automatic starting problems

Hi all,

I own a Renault Megane hatchback 2004 dynamic 1.6 automatic and since I bought it 1 year ago, the car does not always start at the first attempt.

It normally takes 2 or 3 attempts to start the engine, I know very little about cars and worried that this could lead to something more serious.

A few days ago the car didn't start as normally and when started I did a 2mile trip and stopped the car. On the way back the toxic fume indicator light up and the car was juddering a lot and was very difficult to drive, it end up being recovered to a renault garage.

They fixed the car replacing a iginition coil . My first thoughts was that an ignition coil would fix the ignition issues but it didn't. They did fix the toxic fume and the juddering issue.

Any thoughts if there is any serious problem?

I don't know if I should look for any indicator in the panel before starting the car, so getting a bit paranoid if I'm doing anything wrong.
Currently in vulto's garage:
Renault Megane hatchback dynamic automatic
vulto is offline  
  5 Lastest Threads by vulto
Thread Forum Last Poster Replies Views Last Post
Megane dynamic 2004 automatic starting problems Cars & motoring vulto 0 883 18th March 2012 05:43 PM
For the best viewing experience please update your browser to Google Chrome