Renault Forums :: Independent Renault forum - View Single Post - HarryL clio abs problem

View Single Post
post #1 of (permalink) Old 22nd March 2012 Thread Starter
Junior Member
Join Date: Mar 2012
Posts: 2
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
HarryL clio abs problem

My clio(2004 1.2) started to show abs and serv lights. This would clear after engine had been stopped. Took car to auto elec and was told it was teeth corroded on drive shaft rings.Read thread on changing drive shaft abs rings but decided to replace both drive shafts so bought them on ebay (cost 31.99 each).Took abs fuse out to check if this was causing brake judder (abs operating) and it was. Took car to "friendly garage and they fitted both shafts and did a mini service for 80.00.When driving out of garage noticed Toxic fume indicator on.Again read threads on resetting toxic fume indicator and low and behold after approx 50-60 miles the toxic fume indicator light went out. So now have a very happy clio and a very happy driver.
HarryL( PS when inspecting rings on drive shafts both were split so it must have been just the rust holding them on)
Currently in hlawson's garage:
clio 1.2 2004
Currently in touss's garage:
2004 Renault Laguna II 1.9dCi.

Last edited by HeatherJ; 22nd March 2012 at 04:17 PM.
touss is offline  
  5 Lastest Threads by touss
Thread Forum Last Poster Replies Views Last Post
HarryL clio abs problem Brakes/Hubs touss 0 581 22nd March 2012 03:26 PM
For the best viewing experience please update your browser to Google Chrome