Renault Forums :: Independent Renault forum - View Single Post - 2005 Scenic II auto parking brake "force sensor"

View Single Post
post #1 of (permalink) Old 23rd March 2012 Thread Starter
Junior Member
Join Date: Mar 2012
Posts: 3
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
2005 Scenic II auto parking brake "force sensor"

Hello everyone,

I own a 2005 Grand Scenic 1.6 petrol, and the automatic parking brake has had a "force sensor" fault for nearly a year now. I'm thinking about ways to tackle this problem. I recently got the Can Clip tool, and it confirms that the "force sensor" is a current fault in the handbrake system. No other faults indicated.

The error message "Check parking brake" has been on the dash throughout this time, and the brake works fine otherwise, except that the unit appears to always retract/extend the cables through the full stroke when engaging/disengaging, as the engage/release action takes longer compared to when the brake was fully working. The error just appeared on the dash during normal highway driving last winter, and has stayed on ever since.

I've tried to rectify the error by unplugging and plugging the parking brake unit connector, which is located under the chassis near the unit. Are there any other connectors to the unit?

I've been thinking about removing the unit and stripping it down, but I don't know if there are any internal connectors to the sensors and whether the force sensor itself could actually be replaced by soldering.

Any help/advice is appreciated!
Currently in JaskaH's garage:
2005 GS 1.6
JaskaH is offline  
  5 Lastest Threads by JaskaH
Thread Forum Last Poster Replies Views Last Post
2005 Scenic II auto parking brake "force... Brakes/Hubs c9crm 1 3524 23rd March 2012 09:23 AM
For the best viewing experience please update your browser to Google Chrome