Renault Forums :: Independent Renault forum - View Single Post - Cruise Control On The Frits!!

View Single Post
post #4 of (permalink) Old 2nd October 2006
Platinum member
Horatio's Avatar
Join Date: Jul 2005
Posts: 6,475
Nominated 0 Times in 7 Posts
Nominated TOTW/F/M Award(s): 8
Thanks: 0
Thanked 95 Times in 64 Posts
I can't see how you could be doing it wrong, but here's a quick check.

Make sure the switch is in the 'cruise' position (cruise/limiter light on dash is green)
Get up to 60mph in 6th gear.
Press '+' on the steering wheel once.
The display should show your current cruise speed (usually a couple of mph below what the speedo needle is giving you) and the cruise control should engage. If it doesn't, then there's something wrong.

Having said that, I've known it take a couple of stabs of the 'resume' key to get cruise to re-engage after a gearchange. I've also noticed a few quirks in the system - the most ridiculous being the fact that the display switches to 'seet speed limit' when you drop out of cruise. This reads to me as the car being in 'limiter' rather than 'cruise' mode, and confused the hell out of me until I got used to it.

Also, why couldn't they put the cruise/limiter master switch somewhere where you can actually see it while driving? It's another thing that you get used to, but a pain while you're still finding your way around the car.
Currently in Horatio's garage:
2010 Laguna III Initiale.
Horatio is offline  
For the best viewing experience please update your browser to Google Chrome