Renault Forums :: Independent Renault forum - View Single Post - Renault Laguna II 1.9Dci - Engines - Hesitation Cured after EGR cleaned

View Single Post
post #233 of (permalink) Old 2nd May 2012
Diamond member
Join Date: Mar 2012
Posts: 142
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 28
Thanked 8 Times in 8 Posts
Re: Renault Laguna II 1.9Dci - Engines - Hesitation Cured after EGR cleaned

Originally Posted by richardman101 View Post
i agree totally with that madnoel - exactly same scenario with mine last year, but i drove it for a while after cleaning the egr , and several stop/starts after the initial glow light/chugging/wondering what else was broken etc, all power was restored and has been fine since (well, as fine as it can be )
Originally Posted by madnoel10 View Post
I experienced a similar scenario when I disconnected and cleaned my EGR valve. Engine seemed to be in limp mode for around 7 miles or so - its as if the ECU had to relearn its parameters.
glad to see this thread still has followers.

my confusion is the missing part on the maf , its the lower one closest to the mesh, it is missing. i think i can see some of it on the mesh. i have uploaded a picture from the forum to illustrate.

what is its purpose and how is it still working if missing, the new maf has a wire with little white blob in the middle of it.
i have noticed the engine sounds noisier more tappit noise, like my old pigot 405 diesel with mechanical fuel pump.

should i fit the new one and have done with it?
Attached Thumbnails
Click image for larger version

Name:	maf2.jpg
Views:	122
Size:	71.6 KB
ID:	16030  
Currently in ubos100's garage:
2006 laguna 2.0dci 150 sports tourer @ 79100 miles
ubos100 is offline  
For the best viewing experience please update your browser to Google Chrome