Renault Forums :: Independent Renault forum - View Single Post - Accelerator Cable Broken SIX Times

View Single Post
post #9 of (permalink) Old 30th October 2012 Thread Starter
Diamond member
Join Date: May 2012
Posts: 104
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 10
Thanked 3 Times in 2 Posts
Re: Accelerator Cable Broken SIX Times

Originally Posted by coup View Post
There is an old expression "give it some welly", which essentiallu means planting your foot down hard and rapidly on the accelerator.

What I mean is..are you sure the cable follows the exact route the original one did and . there may ..or may not have been a cable support like a bit of wire thicker and stronger than say the wire in a clothes hanger which was attached to a bolt and also clipped on to the outside of the cable to hold it steady.
Haha my old cable, I used to 'give it some welly' all the time and never had a problem with it. I darren't with this one because I know it will snap. I have no idea about the routing- do you think I should take it to an official Renault garage? My last cable had split right down the middle of the wire - there were literally 2 strands of the metal holding it to the accelerator. I don't know if that makes any difference? I know nothing about cars - I just want my cable fixed so I can razz it around a little bit like I used to be able to but I don't know who can fix it properly When I watched the garage fit it - they said it comes as parts where usually it's just a cable with the bits attached that you fit. I don't know if that makes any difference as they had to manually assemble the cable and cut it to size?
Currently in KellyWellyWoo's garage:
Renault Clio 2009 1.2
KellyWellyWoo is offline  
For the best viewing experience please update your browser to Google Chrome