Renault Clio 2001 Dynamique - Brakes juddering - Page 4 - Renault Forums :: Independent Renault forum

LinkBack Thread Tools Display Modes
post #16 of 44 (permalink) Old 19th December 2007
Junior Member
Join Date: Nov 2006
Posts: 6
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Have the same problem with our 51 clio....

Doesn't happen all the time - just intermittently.

Again seems to manifest itself at lower speed braking. Has been there for a year and the car still stops.
Currently in daveat's garage:
clio / espace
daveat is offline  
Sponsored Links
post #17 of 44 (permalink) Old 20th December 2007
Technical Supremo

Join Date: Feb 2007
Posts: 42,935
Nominated 16 Times in 67 Posts
Nominated TOTW/F/M Award(s): 28
Thanks: 371
Thanked 5,199 Times in 4,711 Posts
Hi Dave - could be dirty or duff ABS sensors or sensor rings
Currently in madnoel10's garage:
Honda Civic 1.4l
madnoel10 is offline  
post #18 of 44 (permalink) Old 22nd December 2007
Junior Member
hugh20's Avatar
Join Date: Dec 2007
Posts: 7
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Hi there m8 this is sure to be a broken abs ring. It does have all the symptoms.
hugh20 is offline  
post #19 of 44 (permalink) Old 24th December 2007 Thread Starter
Join Date: Feb 2007
Posts: 43
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 1 Time in 1 Post
Hi Dave,

It is most definately a broken ABS ring. This was indeed the problem with my son-in-laws Clio.

If you jack the car up and remove the wheel, could be either side of course, you will be able to see the ABS ring on the outer CV Joint of the driveshaft. You will need to carefully check all around the toothed ring for any teeth missing or visible cracks on the ring.

In my case the o/s ABS ring was actually rotten through at one point and lifting off the CV joint.

Too difficult a repair for my "kerbside motors" so I had the local garage replace both front rings for good measure along with a new set of discs and pads. Job done.

Repair cost was around 150 including parts though I must add the local garage owner is a personal friend of mine which I'm sure helped a bit.

I must apologise for not updating this forum post but was short of time at the time in question and then it slipped my mind.

Merry Christmas everyone.

Currently in Mitchell_M's garage:
2009 Laguna 1.5dci
Mitchell_M is offline  
post #20 of 44 (permalink) Old 19th January 2008
Junior Member
Join Date: Jan 2008
Posts: 2
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 3
Thanked 0 Times in 0 Posts
Thanks for posting the solution - have the same problem with the wifes 2001 Clio Dynamic AND the daughters Terrano.
twotanks is offline  

brakes , clio , dynamique , juddering , renault

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome