Clio - Heater not woking! - Page 3 - Renault Forums :: Independent Renault forum

LinkBack Thread Tools Display Modes
post #11 of 11 (permalink) Old 5th April 2012
davieclio86's Avatar
Join Date: Sep 2011
Posts: 76
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 8
Thanked 2 Times in 2 Posts
Re: Clio - Heater not woking!

I cured my heating problem by pulling off the hose for the inlet and outlet at the heater matrix, then pouring some brick cleaner in and let it sit for 5 mins to degrade all the sludge. then flush the matrix out with a hose. and that sorted my heating problem
Currently in davieclio86's garage:
Renault Clio Grande 1.2 (2001)
davieclio86 is offline  
Sponsored Links

clio , heater , woking

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome