Renault Clio 2003 - Engines - Loss of power and Warning Light - Page 14 - Renault Forums :: Independent Renault forum

LinkBack Thread Tools Display Modes
post #66 of 322 (permalink) Old 13th December 2007
Join Date: Apr 2007
Posts: 32
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 1 Time in 1 Post
omg wirig loom? ALL the wiring harness inside the engine bay???! It's damn expensive man..
hypermount is offline  
Sponsored Links
post #67 of 322 (permalink) Old 17th December 2007
Junior Member
Join Date: Dec 2007
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Serious problem


My Clio 172Cup has exactly the same problem.
The garage said the throttle bodies were coked up, they charged me 300 to clean. Guess what it did nothing.
If you have any joy please let me know.

Currently in callumhaywood's garage:
2003 Clio 172 cup
callumhaywood is offline  
post #68 of 322 (permalink) Old 28th December 2007
Junior Member
Join Date: Jul 2007
Posts: 25
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 2 Times in 2 Posts
Have to back-up what Louis Chiron's said on here: I had the same intermittent problem and have found the usual chafed wires, so have repaired them.

Whilst it's too early to say if this has cured things in my case, it's clearly a fault.
Currently in tlracing's garage:
51-plate Clio 1.2 Dynamique, 11-plate Clio III
tlracing is offline  
post #69 of 322 (permalink) Old 28th December 2007
Renault Senior Tech
Join Date: Dec 2007
Posts: 259
Nominated 0 Times in 0 Posts
Nominated TOTW/F/M Award(s): 2
Thanks: 1
Thanked 16 Times in 14 Posts
What you need to do it look up behind the Accelerator pedal, there is a green connector with a yellow slide in the middle, it the same connector for the airbag pretensioners under your front seats but a different colour. Theres a tech note out to cut out the connector and solder the wires as the connector is putting the warning light on and causing loss of power as is with the airbag pretensioner connectors for pretensioner related faults. Theres alot of wires in the connector so you may want to take it to renault or an independant garage. This normaly resolves this fault, and you have already had a new throttle potentiometer.
Currently in clio141's garage:
2001 Renault Laguna II 1.8 16v Privilege
clio141 is offline  
The Following User Says Thank You to clio141 For This Useful Post:
Falmor (24th August 2010)
post #70 of 322 (permalink) Old 29th December 2007
Junior Member
Join Date: Dec 2007
Posts: 2
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Angry Throttle Body

I have a 2002 Clio, also blue if that makes a difference. We have just paid #420 to have the throttle body casing repaired for the same problem you mentioned of losing power without warning and only being able to do about 20-30 miles an hour till you stop and turn the car on again. We still have that problem and now the garage are tellling us it is 2 faults. We now need a new wiring loom which will cost about #450. Not sure where we stand on being told it was one thing and paying out and now being faced with another similar bill to fix the original problem. The garage are adamant that there was 2 faults not one.

Anyone got any advice. It seems as if this is a manufacturing problem and as it is potentially very dangerous, should renault not recall the clio and do this work free of charge??
billymog is offline  

clio , engines , light , loss , power , renault , warning

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome