Renault Clio 2003 - Engines - Loss of power and Warning Light - Page 3 - Renault Forums :: Independent Renault forum

LinkBack Thread Tools Display Modes
post #11 of 322 (permalink) Old 30th August 2007
Junior Member
Join Date: Aug 2007
Posts: 12
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Hey that is nearly what happened on mine!!!! Mine cut out in outside lane of motorway VERY DANGEROUS I am just drafting a letter of complaint to renault sasme car mine red and only done 23,000 miles when fault occured THROTTLE BODY 433 POUNDS I PAID
jacqui alive read my account on forum
Currently in jacqui alive's garage:
Renault Clio 2003
jacqui alive is offline  
Sponsored Links
post #12 of 322 (permalink) Old 30th August 2007 Thread Starter
Junior Member
sixteen_valve_vanessa's Avatar
Join Date: Apr 2007
Posts: 8
Nominated 1 Time in 1 Post
Nominated TOTW/F/M Award(s): 1
Thanks: 1
Thanked 6 Times in 2 Posts
Thanks to all for the help and advice.

Currently in sixteen_valve_vanessa's garage:
2003 Renault Clio Expression 1.2 16v
sixteen_valve_vanessa is offline  
post #13 of 322 (permalink) Old 31st August 2007
Diamond member
Join Date: Jul 2005
Posts: 193
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to Dan clio172
I havent read the full thread, so not sure if you solved it, the clio has a problem with the wiring loom, just in the top of the inlet manifold towards the map sensor , the wires wear and what you describe happens. I have found this on several clios, and has always brought up the same fault code.

Dan clio172 is offline  
post #14 of 322 (permalink) Old 31st August 2007
HZlatan's Avatar
Join Date: Aug 2007
Posts: 87
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Cable from throttle potentiometer leads to a connector which is located on clutch pedal. This connector often losses contact. So you have to (or find somebody to do it for you) remove that connector and connect these wires directly. It should work,and it doesn't need extra parts. I already did this many times.
Currently in HZlatan's garage:
1988 R11 1.7
HZlatan is offline  
post #15 of 322 (permalink) Old 1st September 2007
Junior Member
Join Date: Sep 2007
Posts: 6
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
ok i read this thread, let me tell u my story n let me know what u think

the first time i encoutned such a problem was when i stopped at traffic lights, it was downhill, so not a problem to stall really.

lights go green, i go, but within 3 second, the car died out as iff someone pulled the plug on it. so i drifted along with no power, just the accelaration i had at the time for about 5 meters n then the car came back into power again, n off i first thoughwas the petrol but that was failry full but i filled up neverthe less....

this was about 3 weeks ago, and since then i encoutned no problems...

today, my petrol as on 15 minutes past on the metre pointing ---> this way, so its half full.....

i think my car died out 4 times , luckily the car come back to life within 3-10 seconds, but i have to do the ignition again, and sometimes it occurs right after, so it takes me a few attempts to finally go......

i noticed that the first light i notice is the power assisted steering light, the one that looks like a steering wheel

to be honest though, its such a panicky situation that happens so fast i dont know which lights exaclty come up n not...
but to sum it up, my car loses all power no lights nothing for anything between 3-10 seconds.....alsmot like it has stalled, but it hasnt...

i have also noticed a hell of a lot of cliking around the dashboard and the steering whell and the electronics, i have reason to belive one this problem was triggered by me indicating to the right, but this could just be a coincidence....

does this sound like the same problem ?? i would like your opoinions as i am going to take this to the renault deals and would like to know what to say

the car is a renault clio authentique 2003 and i am totally inexperienced drving for 6 months and not fluent in my car knowlege so im very worried...

thnk you
Currently in eSo's garage:
renault clio 2003
eSo is offline  

clio , engines , light , loss , power , renault , warning

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome