Renault Clio 2003 - Engines - Loss of power and Warning Light - Page 4 - Renault Forums :: Independent Renault forum

LinkBack Thread Tools Display Modes
post #16 of 322 (permalink) Old 1st September 2007
Technical Supremo

Join Date: Feb 2007
Posts: 42,935
Nominated 16 Times in 67 Posts
Nominated TOTW/F/M Award(s): 28
Thanks: 372
Thanked 5,199 Times in 4,711 Posts
Hi Eso - your problem sounds very much like a break in the electrics. I had similar situation witha Megane which I eventually tracked down to a broken earth connection on the engine - it would make a few of the solenoids go bananas and start to click. I suggest you get the earth cables to the battery and engine checked out as it appears you engine is experiencing sudden bouts of power failure.
Currently in madnoel10's garage:
Honda Civic 1.4l
madnoel10 is offline  
Sponsored Links
post #17 of 322 (permalink) Old 2nd September 2007
Junior Member
Join Date: Aug 2007
Posts: 12
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts

Hi eso

Your problem could be a wiring problem A mechanic and road side recovery personnel told me that this is a common problem with clios I would get it checked out I know how scary it is and dangerous for all Hope you get it sorted
Currently in jacqui alive's garage:
Renault Clio 2003
jacqui alive is offline  
post #18 of 322 (permalink) Old 2nd September 2007
Junior Member
Join Date: Sep 2007
Posts: 6
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
hi me again

ok regarding me problem.. i wanted to add something....i spoke in my main post about it happening then not happening for 3 weeks n then it happening again..

i recall some saying this same- ish problem occuring in the summer, but no tin the winter... this lead me to remember that on both occasions, the days were extremely hot....

i.e the inside of the car was hot, n the moment i put the power on, there were numerous clickign noises coming from everywhere.......

would this be a significant point to make ??? id so what could be the cause of the problem and a possilbe solution..

also to those who wrote about thier problems did it occur more regulalry when the day was hot???

thnk you
Currently in eSo's garage:
renault clio 2003
eSo is offline  
post #19 of 322 (permalink) Old 3rd September 2007
Junior Member
Join Date: Aug 2007
Posts: 19
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 6 Times in 2 Posts
Hi eSo,

I think my problems tended to occur in the damper months (Octoberish and then again in February). Mostly these were after damp nights.
I don't know if the weather conditions/temperature has anything to do with this problem - there are other problems related to water ingress on clio's (antenna, sunroof etc) so that could be something different.

Good luck with the dealer. Don't let the pretend they've never heard of this problem before. It's amazing how often dedicted Renault dealers seem to be the last to know about common(ish) problems with their cars!
Currently in LOUIS CHIRON's garage:
52-plate Clio Expression 1.2, 3dr manual
LOUIS CHIRON is offline  
post #20 of 322 (permalink) Old 12th September 2007
Join Date: Apr 2007
Posts: 56
Nominated 0 Times in 1 Post
Nominated TOTW/F/M Award(s): 1
Thanks: 0
Thanked 1 Time in 1 Post

this happened to me, they replaced the engine wiring loom did something with pedels I couldnt make the fella out was I was cryin over so much lost money but yet mine is still knackered! In all honesty im thinking of selling it and getting a 182 because I just cannot be bothered with that, I was also going down the motorway 70mph and it died, it scares the **** out of you when you are on the outside lane and all of a sudden you lose power with buses and lorrys behind you.. total bloody joke. I also see that its just not me thats had this problem, makes me think renault should be paying for this not the drivers!


(P.S Its still ¤¤¤¤ed and im not paying any more money! spend over £450 and its still broken, same problems.)
Currently in adam1942's garage:
2007 Renaultsport Clio 197 F1

Last edited by adam1942; 12th September 2007 at 01:49 PM.
adam1942 is offline  

clio , engines , light , loss , power , renault , warning

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome